IPitomy IPitomy Smarter Business Communications

Q Manager


Current Software Information

Current Release Version: 1.4 (Updated: 3/19/13)

Release Notes

Note this software requires that the PBX be running 4.6.1 or newer to function. You must be running 4.8.0+ for chat support.

Installer (Note you may need to be running Internet Explorer to Run this)

Installation Tips: You don't need to run this in internet explorer. You can simply download the file pointed to by the "Launch" link. This file is a .application file. If you have .NET framework 4.0 installed. You just need to double click on this file after downloading it in any browser.

If you are running Windows 8 and the application states that it is from an unknown publisher, click the link to "More Info" and then click the newly revealed "Run Anyway" button.